Follow

Database Password Requirements for PHP

  • Applies to: Grid
    • Difficulty: Easy
    • Time Needed: 5
    • Tools Required: Account Center Access

Overview

As part of our ongoing effort to maintain and improve upon the security of the Grid, some Media Temple customers that wish to upgrade their PHP version will be required to update their database passwords. This is due to a change in the password hash requirements for PHP. Customers that are impacted by this change may see one or more notifications in their Grid Account Center prompting them to update their database passwords prior to upgrading PHP. 

 

If you are affected by this new requirement and have any specific questions that are not answered here, we encourage you to contact Media Temple's 24/7 support

Questions

 

How do I know if I'm affected?

  • You may see one or more prompts similar to this in your Grid Account Center:

To update your database passwords, click on Manage Database Users and follow the instructions.  

What happens if I don't update impacted passwords?

  • You will be prevented from making PHP version changes until all impacted passwords have been updated, which prevents you from taking advantage of performance improvements provided by newer PHP versions.

 Can I use the same passwords?

  • You may use the same secure password as long as it conforms to current security standards. The password simply needs to be re-saved in order to update the encryption method.

 What will happen if I change an impacted password to something new?

  • Your app or service that uses that database may be adversely affected until its configuration is updated to use the new password. You may re-save the same secure passwords.

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk